Operating systems and browsers

For security reasons, you should always use the latest version of your operating system/browser. Install available updates and do not use beta versions. Please note that PostFinance does not support browser extensions (add-ons).

Supported operating systems

Operating systemVersion
Operating system
Windows 8.1 
Version
-
Operating system
Windows 10
Version
From Version 21H2
Operating system
Windows 11
Version
From Version 21H2
Operating system
MacOS
Version
From Version 10.15

Supported browsers

BrowserOperating system
Browser
Microsoft Edge from version 102
Operating system
Windows 10 or 11 (from version 21H2), Windows 8.1
Browser
Firefox from version 103
Operating system
Windows 10 or 11 (from version 21H2) / MacOS (from version 10.15)
Browser
Google Chrome from version 102
Operating system
Windows 10 or 11 (from version 21H2) / MacOS (from version 10.15)
Browser
Safari from version 15
Operating system
MacOS (from version 10.15)
Browser
SecureBrowser 5.4
Operating system
Windows 10 or 11 (from version 21H2) / MacOS (from version 10.15)

The use of other products or operating systems and browser versions is at your own risk and no support will be provided by PostFinance in such cases.